Соединение с базой MSQL (Проблемма)

Пытаюсь подключить скрипт занесения данных из результатов парса в базу на сервере. При обращении к скрипту выдает 500 Internal Server Error. До этого я обращался в супорт хостинга, они вроде все настроили, понизили версию на сервере, что то еще подшаманили, скрипт стал подгружать данные в базу. Но начали появляться траблы в магазине: перестал работать один из основных модулей(он только под 7 версией работает) появились проблемы с оформлением заказа, с импортом CSV файлов. Вот я поставил 7 версию, подправил досуп к папкам, магазин стал нормально работать, но возникли проблемы с подгрузкой в базу. Может проблема в 7 версии?

Вот переписка с администрацией хостинга: рого времени суток, ув. администрация. 500 Internal Server Error) , я обращался 2020-06-16 15:39:40 по поводу решения проблем с занесением данных в базу MSQL. После решения денной проблемы , при проверке магазина было обнаружено 1. Перестал работать основной модуль, (В тех. поддержке магазина написали,что модуль работает На PHP выше 7 версии, я повысил версию модуль заработал) 2. Перестал работать модуль Импорта Экспорта( были поменяны права доступа на папку экспорт, модуль заработал) 3. При оформлении заказа в магазине не работал скрипт подтверждения заказа, проблему решил установкой прав на папку /cache/quick_view/. После всех манипуляций магазин заработал, но проблема при запуске скрипта -------/obnovlenie_cen.php повторилась (HTTP/1.1 500 Internal Server Error): Здравствуйте!
При открытии данной страницы в логах вижу следующую ошибку

[Tue Jun 23 12:11:12 2020] [error] [client 195.123.209.64] PHP Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /var/www/www-root/data/www/musicalka.com.ua/obnovlenie_cen.php:2\nStack trace:\n#0 {main}\n thrown in /var/www/www-root/data/www/musicalka.com.ua/obnovlenie_cen.php on line 2

Проверьте какой модуль php используется для обращения к базе. например mysql не поддерживается на новых версиях php. на новых версиях php есть его аналог mysqli или mysqlnd. Они оба подключены для Вашей версии php. Для указания корректного синтаксиса кода при подключении данных расширений Вам нужно обратиться к разработчику Вашего сайта или к профильному специалисту.

Вам нужно доработать свой файл obnovlenie_cen.php для совместимости с php 7.2

Спасибо. проблема решена использованием mysqli запросов

1 Симпатия